Cet article fait partie d’une série consacrée à Google Sheets.
Vous pouvez copier
le fichier exemple pour retrouver toutes les formules utilisées dans les Cas pratiques.


Google Sheets donne une toute autre dimension au travail des données grâce à des centaines de fonctions différentes. La liste complète des fonctions de Sheets détaille le fonctionnement de chacune d'elles. 

Il a été très difficile de n'en retenir qu'une poignée tant les possibilités offertes sont nombreuses.  Mais que ce soit pour préparer un budget ou prendre des décisions stratégiques, les entrepreneurs ont besoin de pouvoir analyser vite et bien leur données. Nous avons alors posé la questions aux utilisateurs de Tactill et voici les fonctions qu'ils utilisent le plus. 

Nous les avons toutes décortiquées pour que vous puissiez les appliquer facilement dans votre entreprise. Faites en bon usage, et surtout, pensez à nous partager vos astuces. Nous serons ravis de les présenter dans nos prochains articles.

SOMME (SUM) 

Reine des fonctions, sa simplicité est sa plus grande force. Il suffit de donner une série de nombres et / ou de cellules à SOMME pour qu'elle en calcule la somme.

=SOMME(A2:A100)
=SOMME(1;2;3;4;5)
=SOMME(1;2;A2:A50)


SOMME.SI (SUM.IF)

SOMME.SI ressemble beaucoup à SOMME à qui elle ajoute un peu  de subtilité. Comme son nom le laisse penser, SOMME.SI calcule une somme si un condition est remplie. Elle prend au moins deux paramètres en entrée : 

  • la plage qu'on teste par rapport à une condition (ou critère) et qui sera additionnée si on ne précise pas le contraire

  • une condition qui doit être respectée pour que la valeur soir additionnée

  • une plage de somme optionnelle 

Elle s'écrit de la façon suivante

=SOMME.SI(plage; critère; [somme_plage])

Cas pratique
Pour trouver la somme des tickets dont le total est supérieur à 30€ nous utilisons :

=SOMME.SI(C2:C6;">30")

SI (IF)

Avec SOMME.SI, nous avons découvert la notion de condition qui permettait de prendre une valeur en compte, on non, dans le calcul d'un somme.
La fonction SI teste si une condition est vraie, et elle affichera tel résultat si la condition est vraie et tel autre si elle est fausse.

Elle prends trois paramètres d'entrée :

  • une condition_logique à tester. par exemple A1 > 10 ou A1 = "client"

  • une valeur_si_vrai qui sera affichée si la condition_logique est vraie

  • une valeur_si_faux qui sera affichée si la condition_logique est fausse

=SI(condition_logique, valeur_si_vrai, valeur_si_faux)

Cas pratique
Pour savoir si un ticket de caisse a été payé par un client connu ou par un anonyme, on cherche à savoir si la cellule du nom du client n'est pas vide ( <>"" ). Si la cellule n'est pas vide, on affiche "connu", on affiche "anonyme" sinon. Ce qui se traduit par :

=SI(D2<>"";"connu";"anonyme")

RECHERCHEV (VLOOKUP)

RECHERCHEV (pour recherche verticale) recherche une valeur dans la première colonne d'une plage donnée. Elle affiche ensuite la valeur d'une cellule dont l'index est spécifié dans la ligne trouvée et sa syntaxe est la suivante :

=RECHERCHEV(clé_recherche; plage; index; [est_trié])


Pour précisément, elle cherche une valeur (clé_recherche) dans la première colonne d'un tableau (plage).
Quand elle trouve la valeur, elle connait la ligne à laquelle elle est. Grâce à l'index qui lui est donné en 3e paramètre, RECHERCHEV connait la cellule qu'elle doit renvoyer. Ainsi, on donne "2" en index si on veut afficher la valeur de la 2e colonne de la ligne trouvée.  Enfin, est_trié peut être VRAI ou FAUX en option pour indiquer si la première colonne de la plage est triée ou non.

Cas pratique
RECHERCHEV
est parfaite pour répondre à des questions précises. Par exemple, pour connaitre le montant total du ticket N°127, on utilise :

=RECHERCHEV(127;A2:D6;3;VRAI)

Dit autrement, on cherche la valeur 127 dans la plage A2;D6 , on affiche la troisième colonne de la ligne trouvée, et on indique que la première colonne du tableau est triée.


MOYENNE (AVERAGE)

MOYENNE calcule la valeur moyenne d'une plage de données. La bonne nouvelle c'est que si la plage contient du texte, moyenne n'en tiendra pas compte. Elle s'utilise comme SOMME et vous permet notamment de calculer votre panier moyen et bons nombres d'indicateurs indispensables à votre business.

MOYENNE(A2:A100;B2:B100;4;26)
MOYENNE(1;2;3;4;5;C6:C20)

Cas pratique
On veut connaitre le panier moyens des tickets encaissés. On utilise pour ça :

=MOYENNE(C2:C6)


COUNTUNIQUE

COUNTUNIQUE permet de compter le nombre de valeurs d'une plage de données. Cette fonction vous permet par exemple de compter le nombre de clients différents que vous avez encaissé. Bien entendu, une cellule vide ne compte pas comme une valeur unique et elle s'utilise de la façon suivante :

=COUNTUNIQUE(valeur1, [valeur2, ...])
  • valeur1 est la première valeur / plage dont ont compte les valeurs uniques

  • valeur2 et les autres sont facultatives mais peuvent être ajoutées si besoin

Cas pratique
Pour connaitre le nombre de clients différents dans les tickets encaissés, on utilisera :

=COUNTUNIQUE(D2:D6)


A vos claviers 

Nous pourrions continuer indéfiniment ce catalogue tant les fonctions de Sheets sont nombreuses. Mais si l'on s'en remet à l'adage, la meilleure façon de les découvrir est de les utiliser. Alors lancez-vous ! 

Posez des questions à vos données et utilisez la liste complète des fonctions dès que vous en sentez le besoin. Il suffit de taper quelques mots clés pour trouver la fonction qui convient à votre usage.

SUBSTITUE et JOIN sont par exemple de bonnes introductions aux fonctions de texte. Celles-ci vous permettant de gérer facilement de grands ensembles de texte, elles s'avèrent particulièrement efficaces quand il s'agit de manipuler des références ou des désignation d'articles. 

Et comme toujours, si un problème vous résiste, Google a certainement la solution.


Dans le prochain article, nous aborderons la question du tri dans Google Sheets. Vous y découvrirez comment déceler les tendances qui se cachent dans vos données. Bonne lecture ! 

Continuer la lecture 

Avez-vous trouvé votre réponse?